Playbook app is unavailable in some regions

Incident Report for Playbook Platform

Postmortem

Due to a global outage in our upstream provider (Cloudflare), the app was unavailable in some regions.

Posted Nov 18, 2025 - 04:28 PST

Resolved

Our upstream provider has resolved their issue.
Posted Nov 18, 2025 - 06:45 PST

Investigating

We are currently investigating an issue with our upstream provider.
Posted Nov 18, 2025 - 03:45 PST
This incident affected: Playbook Web.