Upload Issues
Incident Report for
Playbook Platform
Resolved
Cloudflare has fixed the issue and systems are operational again.
Posted
Feb
16
,
2026
-
03:58
PST
Identified
Our downstream provider Cloudflare is currently having issues, which is impacting uploads. Uploads may error until their incident is resolved.
Posted
Feb
16
,
2026
-
03:03
PST
This incident affected: Playbook Web and Playbook Mobile.
×
Subscribe to Incident
Subscribe to updates for
Upload Issues
via . You'll receive .