Email delivery from Playbook is currently degraded

Incident Report for Playbook Platform

Resolved

This incident has been resolved.
Posted Apr 23, 2025 - 05:00 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 23, 2025 - 05:00 PDT

Identified

Email notifications, including magic links, may be delayed.
Posted Apr 23, 2025 - 04:56 PDT
This incident affected: Playbook Web.