Uploading issues for Artist & Designer plan
Incident Report for
Playbook Platform
Resolved
We are continuing to work on a fix for this issue.
Posted
Apr
17
,
2025
-
13:42
PDT
Update
We are continuing to work on a fix for this issue.
Posted
Apr
17
,
2025
-
13:42
PDT
Identified
The issue has been identified and a fix is being implemented.
Posted
Apr
17
,
2025
-
13:19
PDT
This incident affected: Playbook Web.
×
Subscribe to Incident
Subscribe to updates for
Uploading issues for Artist & Designer plan
via . You'll receive .