Upload Issues

Incident Report for Playbook Platform

Resolved

This incident has been resolved.
Posted Jul 17, 2026 - 12:35 PDT

Monitoring

The downstream provider has fixed their issue. Uploads should stabilize back to normal
Posted Jul 17, 2026 - 09:32 PDT

Investigating

We're currently investigating an downstream provider issue for our uploading process causing intermittent failures.
Posted Jul 17, 2026 - 07:15 PDT
This incident affected: Playbook Web and Playbook Mobile.