Delayed delivery of email login links

Incident Report for Playbook Platform

Resolved

This incident has been resolved.
Posted Apr 15, 2026 - 10:22 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 15, 2026 - 10:22 PDT

Investigating

Some users may experience delays receiving one-time login links via email. Login functionality is not down — links are still being delivered, but slower than expected.

We are actively investigating the cause and will provide updates as we have them.
Posted Apr 15, 2026 - 06:30 PDT
This incident affected: Playbook Web.