Asset previews missing
Incident Report for
Playbook Platform
Resolved
This incident has been resolved.
Posted
Mar
06
,
2026
-
14:31
PST
Monitoring
A fix has been implemented. We are continuing to monitor performance as our systems fully stabilizes.
Posted
Mar
06
,
2026
-
11:41
PST
Identified
Asset previews have now been restored. Some related features may still be recovering as our systems finish stabilizing.
Posted
Mar
05
,
2026
-
17:36
PST
Investigating
We are investigating an issue where asset previews are not displaying. All files remain safe. Our team is working on recovering the previews.
Posted
Mar
05
,
2026
-
14:06
PST
This incident affected: Playbook Web and Playbook Mobile.
×
Subscribe to Incident
Subscribe to updates for
Asset previews missing
via . You'll receive .